SSD, HDD, Clonen, WTH, MFG, Computerproblem, nur bedingt Forenthema

  • Okay, ohne PC komme ich nicht ins Forum.

    Also doch Thema.


    Ich dachte ja, ich kenne mich aus. Hatte mal in der Branche gearbeitet.

    PC Bau nach Kundenwunsch. Comtech. Lange her.


    Ich habe mir eine 7 Jahre alte HP Workstation gekauft für 70 Euro, um sie mir als Gaming PC herzurichten.

    Die Basis ist gut. Wie ein alter Unimog. Stabil und gute Qualität.

    Sie, die Workstation kam für 70 Euro bereits mit Intel i7 3770 fixed, einer Nvidia Quadro 410 Graka, 8GB RAM und einer 1TB WD Platte.

    Gute Basis eben. SATA Anschlüsse, Slots für noch mehr RAM und PCIe 3.0 16x.

    Top aktuell, erweiterbar.


    Ich habe dann erst mal eine SSD von Samsung rein gemacht an den zweiten SATA Port.

    Eine MSI Geforce 1050 mit 4GB, nochmal 2x 8GB RAM und ein Coolermaster CPU Wasserkühlungsset kam noch mit rein.

    Ich nutze das Samsung Tool "Data Migration" fürs Clonen der vorhandenen Platte sowie Samsung Magician um die SSD optimal einzurichten.

    An Notebooks habe ich das schon öfter gemacht und das hat immer super funktioniert.

    Auf der vorhandenen 1TB Platte ist auch das Windows 10 installiert, als Wiederherstellung mit Key.

    Darum der Auwand mit dem Clonen.


    Jetzt kommts. Das System startet immer noch von der alten HDD, und nicht wie geplant von der schnelleren SSD.

    Bisher bei Notebooks, wo die alte Platte raus kam, was das nie ein Thema.

    Aber hier bleibt ja die 1TB HDD drin.

    Ziehe ich den SATA Stecker ab, bootet das System sauschnell von der SSD. So wie es sein sollte.

    Sind beide angeschlossen, bootet das System von der alten HDD.


    Ich habe schon folgendes gemacht.

    Abgesichert neu gestartet, Eingabeaufforderung, Format der HDD.

    Dauerte ewig. Keine Besserung.

    Startet jetzt immer noch von der alten HDD, bleibt aber stecken im Wiederherstellungsprozess.

    Versucht das System wiederherzustellen, da ist aber nix mehr.


    Was muss ich machen um die alte HDD nicht mehr bootfähig zu machen?
    MBR kenne ich noch von früher. Masterbootrecord.

    Wie kann ich den verändern?

    Im BIOS ist die Bootreihenfolge korrekt gesetzt.

    Leider kann man dort nur allgemein "boot from HDD SSD" und nicht direkt auswählen, WELCHE genau.


    Vielleicht hat jemand schonmal das gleiche Problem gehabt und kann mir da einen Tip geben.

    www.gürtel-extreme.de

    Casström Messer und Jagdzubehör, Gürtel in Handarbeit, Ticket to the Moon Vertrieb


    SAVE THE DATE:

    30.04. - 04.05.20 Hängemattenforum Sommer Treffen Mengerschied

  • Ich melde mich mal als einer, der eigentlich keine Ahnung vom Thema hat, aber seinen PC schon ein paarmal abgeschossen und wieder zum Laufen gebracht hat.


    Einmal hat mir Easy BCD geholfen. (Wenn du runter scrollst, gibt's eine nicht-kommerzielle Version.)

    Ob du damit allerdings deinen nicht richtig bootenden Computer zum Laufen bekommst respektive richtig konfigurieren kannst...


    Ich bin sicher, in diesem Forum bekommst du noch professionelle Hilfe!

  • Funktioniert aber von der Logik her nicht.

    Denn um die alte HDD zu bearbeiten, muss ich sie anschließen.

    Tue ich das, versucht ja der PC von ihr zu booten.

    Nachträglich anschließen, nachdem von der schnellen SSD gebootet wurde gibt ein Freeze.


    Das empfohlene Programm hab ich installiert und es findet alles okay.

    1 Betriebssystem, 1 Platte.


    Ich muss ohne Windows, ein "DOS Ebene" das Problem lösen.

    www.gürtel-extreme.de

    Casström Messer und Jagdzubehör, Gürtel in Handarbeit, Ticket to the Moon Vertrieb


    SAVE THE DATE:

    30.04. - 04.05.20 Hängemattenforum Sommer Treffen Mengerschied

  • Das habe ich befürchtet. Deshalb steht wohl auf der Website auch, dass das Programm keinen nicht-bootenden Computer zum Laufen bringt. Ich hatte gehofft, dass sich vielleicht die «sich einmischende» Festplatte erst nachträglich anschliessen lässt. Aber mit dem Einfrieren wurde das nun auch nichts. Schade.


    Ich weiss auch nicht mehr, wozu ich damals das Programm installiert hatte. Irgendetwas war da mit dem Bootsektor kaputt gewesen. Und mit wenigen Klicks lief alles wieder.

  • Hab jetzt mit DISKPART auf Eingabeebene gearbeitet. Da scheiterts halt an den Fachbegriffen.

    Inactive partition wäre der richtige Befehl, kann aber den Datenträger nicht definieren.


    In ein Linux einlesen wegen einer Festplatte die nicht will, kann man machen.


    Man kann aber auch die Festplatte geschmeidig bei Ebay verticken und sich eine andere Festplatte kaufen.

    Problem solved... Redneck Style.

    www.gürtel-extreme.de

    Casström Messer und Jagdzubehör, Gürtel in Handarbeit, Ticket to the Moon Vertrieb


    SAVE THE DATE:

    30.04. - 04.05.20 Hängemattenforum Sommer Treffen Mengerschied

  • Eine andere Platte wird das Problem nicht lösen, da die Platte nicht das Problem ist. Genau genommen ist deine Methodik zum Kopieren das Problem - eine Platte einfach zu klonen funktioniert mit UEFI-Systemen nur bedingt. Du wirst nicht darum herum kommen, dich mit dem Initialisierungsprozess von UEFI auseinander zu setzen... Das Tool efibootmgr vor einer Linux-CD dürfte helfen. Damit kannst du dann den richtigen Loader bestimmen - also den auf der EFISYS-Partition der SSD.

    haengemattenforum.de Ich bin zwar nur der Haustechniker, aber wenn es Probleme gibt kann ich wahrscheinlich helfen ;).
  • Ich kann ja auch nur auf gefährliches Halbwissen wie Waldläufer70 zurückgreifen, dennoch folgende Idee:


    Die HDD physikalisch vom System isolieren, indem du ihr den Stecker ziehst. Das System mit der alleinigen SSD booten und dann noch einmal diese auf Boot-Position 1 im BIOS erneut abspeichern. Danach wieder die alte HDD ins System reintegrieren und schauen, ob das BIOS die SSD-Konfiguration behalten hat.


    Allerdings meide ich Windows-Betriebssysteme, wie der Teufel das Weihwasser. Bei mir hat mein beschriebenes Verfahren geklappt, als ich die geschrottete (Ex-Windows)-HD eines Acer All-in-One-Rechners austauschen musste und Linux auf der neuen bereits vorinstalliert hatte. Die Platte wurde auch nicht von den alten BIOS-Einstellungen als Primär-Bootmedium anerkannt (und eine andere Platte gab es zu dem Zeitpunkt nicht im System). Der Rechner kam über die BIOS-Fehlermeldung nicht hinaus.

  • Hm, nochmal zum Thema gefährliches Halbwissen: Die beschriebene Problematik hat mit dem Betriebssystem nichts zu tun. Das Problem wäre mit Linux in der selben Situation genau so aufgetreten. Die Ursache ist letztlich darin, wie ein UEFI-BIOS seine Loader sucht. Das Verfahren funktioniert (vereinfacht) folgendermaßen:

    • Warte auf Datenträger
    • Lade Treiber für alle gefunden Datenträger
    • Suche nach dem benutzerdefinierten Loader (wird normalerweise bei der Betriebssysteminstallation festgelegt). Dieser Eintrag besteht aus der Geräte-ID der Festplatte, der Parititions-ID der EFISYS-Partition auf der Platte und dem Namen des Loaders auf der Partition.
    • Suche nach weiteren Loadern auf der selben Platte
    • Suche nach weiteren EFISYS-Partitionen mit Loadern (in der festgelegten Reihenfolge)

    Die eingestellte Bootreihenfolge ist also der letzte Schritt in der Suche! Eigentlich sollte die Suche so lange weiter laufen, wie kein gültiger Loader gefunden wurde. Leider sind viele UEFI-Implementationen ziemlich "kaputt" und hängen sich auf, wenn ein benutzerdefinierter Loader eingetragen aber nicht gültig ist (beispielsweise, weil sich die Geräte-ID geändert hat).


    Der einzige Weg, das zu reparieren, ist, den benutzerdefinierten Loader wieder richtig zu definieren. Also letzten Endes, das zu wiederholen, was Windows (oder der Installer der bevorzugten Linux-Distro) bei der Loader-Installation gemacht hat. Dafür wäre das Tool efibootmgr gut geeignet.


    Kleiner Nachtrag: MBR ist seit gut 10 Jahren erledigt. Es gibt ihn noch und ein UEFI-BIOS im Kompatibilitätsmodus kann ihn auch lesen, aber üblich ist das nicht mehr. Aktuell werden die Loader in einer kleinen (200-500MB) FAT32-Partition installiert. Diese ist üblicherweise in GPT-Slot 0 und hat das Label EFISYS. Das ist aber beides (theoretisch) nicht notwendig...

    haengemattenforum.de Ich bin zwar nur der Haustechniker, aber wenn es Probleme gibt kann ich wahrscheinlich helfen ;).
  • Also ein Clone wäre ja schon lauffähig.

    Freie Programme wie MiniPartitionTool oder MacronReflect kann ich hier empfehlen. Nutze ich oft, wenn es mit Acronis True Image nicht funktioiert.

    Kann hier gerne Remote Hilfe anbieten.

  • SirWesley, Danke für die Tips, aber Du hast das Problem nicht verstanden.

    Wenn beide Platten dran sind, kein Windows, keine Tools, keine Apps.


    Ich habe dann einen Ubuntu USB Stick erstellt und von dem gestartet.

    Dauert ewig, liegt am Stick. Läuft aber.

    Leider konnte efibootmgr nicht runtergeladen werden obwohl eine Netzwerkverbindung besteht.

    Ich hab da wieder eine Stunde versenkt und dann den Krempel in die Schwarze Tonne geworfen.

    Virtuell.

    Danach, den Stick raus, gestartet. Nix mehr. Langes piepen, bleibt noch bevor ich ins BIOS kann, hängen.

    WTF???

    Er liegt ja schon mit offenem Seitenteil vor mir und ich konnte alle Stecker nochmal checken.

    Nichts.

    Dann wurds mir zu buntu und ich hab die Knopfzelle vom Bios Speicher raus. 21 22 23... wieder rein.

    Basis Einstellungen wurden geladen, gemecker wegen der Uhrzeit und das Ding läuft wieder.

    Ich habe dann nichts mehr dran gefummelt bis auf unnötige Laufwerke in der Boot Reihenfolge wie CD DVD, USB Floppy etc.

    Nur noch die Option HDD.

    Mit EFI red ich nichts mehr. Die dumme Kuh kann mich mal.

    Solange der PC so läuft wie jetzt, meine Games laufen, mach ich da dran nix mehr.

    Soll ja erstmal nur Gaming PC sein bis nächstes Jahr der Windows 7 Support endet und mein treues ehrliches DELL Latitude 5520 keinen Support mehr erhält. Das lief immer. Kaffee drüber, ausgeleert, läuft. Runter gefallen, läuft...


    Danke Allen für die Tips!

    www.gürtel-extreme.de

    Casström Messer und Jagdzubehör, Gürtel in Handarbeit, Ticket to the Moon Vertrieb


    SAVE THE DATE:

    30.04. - 04.05.20 Hängemattenforum Sommer Treffen Mengerschied

  • Dubioserweise laufen jetzt beide Platten problemlos.

    Von der SSD wird gestartet und die 1TB HDD ist ganz normal da. Leer, mit Lauwerksbuchstabe und Bezeichnung.

    Kann drauf schreiben und lesen.

    Warum? Keine Ahnung.
    Efi´s Bootmanager konnte ich ja nicht runterladen.

    Vielleicht hat das reine Ausführen eines Linux was bewirkt oder eben das Entfernen der Bios Batterie.


    Doof nur, ich war schon so voreilig und hab mir bei ebay eine neue WD 1TB Platte gekauft.

    Jetzt hab ich halt 2.

    Schadet nie.

    www.gürtel-extreme.de

    Casström Messer und Jagdzubehör, Gürtel in Handarbeit, Ticket to the Moon Vertrieb


    SAVE THE DATE:

    30.04. - 04.05.20 Hängemattenforum Sommer Treffen Mengerschied

  • Mir fällt ein, dass ich bei meinem Acer-Projekt am Ende auch die BIOS-Batterie ausgetauscht habe, um überhaupt wieder in die BIOS-Einstellungen zu kommen (mit F2 hat er mir davor immer nur ganz kurz das "American Megatrends"-Logo angezeigt und ich konnte gar nicht tiefer gehen – die Batterie war als ich nachgemessen habe tatsächlich auch leer). Danach war das BIOS ganz frisch. Vielleicht hatte es tatsächlich damit etwas zu tun ... oder es ist einfach Voodoo :/


    Auf jeden Fall Dir viel Erfolg bei der weiteren Konfiguration!